GKCmaTV.fr.st / GKC.fr.st Forum Index  
  Search  •  Memberlist  •  Usergroups   •  Register  •  Profile  •  Log in to check your private messages  •  Log in

There is no tips defined in your language

[]

To help us to fill this box, you can create your own tips, or translate the other languaqe's tip

 Pb de FullScreen avec XdTV et Dual Screen View next topic
View previous topic
Post new topicReply to topic
Author Message
Kheo
Posteur régulier


Joined: 27 Feb 2003
Posts: 55
Location: Coucou, je suis là ! mais ou tu regardes, j'ai dis ici !!

PostPosted: Wednesday 2 June 2004 21:09:21 Reply with quoteBack to top

Voila je suis sous la Debian, et j'ai un pb qd je passe en Dual Screen ( deux DISPLAY pour le serveur X ) ben qd je me met en fullscreen, j'ai une petite fenetre riquiqui et j'ai meme plus de desentrelacement dans le panneau de config de xawdecode.

Une idée ?
View user's profileSend private messageMSN Messenger
BlindMan
Modérateur


Joined: 06 Apr 2002
Posts: 9962

PostPosted: Monday 7 June 2004 12:51:05 Reply with quoteBack to top

Il faudrait que je trouve le temps de configurer le dualscreen avec xdTv
Le pb, c'est dès que je lance xdTv, le pc freeze...... merci les drivers ATI confused

Sinon, xvinfo te dit quoi??
Tu as regardé si les extensions XVideo étaient utilisées??
View user's profileSend private messageVisit poster's website
pingus
Dévelo XdTV (Linux)


Joined: 21 Dec 2002
Posts: 194

PostPosted: Monday 7 June 2004 23:09:51 Reply with quoteBack to top

par defaut c'est pas compilé nativement:
./configure --enable-xinerama
View user's profileSend private message
Kheo
Posteur régulier


Joined: 27 Feb 2003
Posts: 55
Location: Coucou, je suis là ! mais ou tu regardes, j'ai dis ici !!

PostPosted: Wednesday 9 June 2004 20:49:03 Reply with quoteBack to top

Ah ben merde j'ai pa recu de mail pour me dire que quelqu'un m'avait repondu.
Bon je viens de voir vos reponses et merci deja. Pour BM voila :

Code:

21:43 kheo@nolen ~% xvinfo
X-Video Extension version 2.2
screen #0
 no adaptors present
screen #1
 no adaptors present


ma config avec un ecran => xvinfo donne :
Code:

X-Video Extension version 2.2
screen #0
  Adaptor #0: "ATI Radeon Video Overlay"
    number of ports: 1
    port base: 67
    operations supported: PutImage
    supported visuals:
      depth 24, visualID 0x23
      depth 24, visualID 0x24
      depth 24, visualID 0x25
      depth 24, visualID 0x26
      depth 24, visualID 0x27
      depth 24, visualID 0x28
      depth 24, visualID 0x29
      depth 24, visualID 0x2a
      depth 24, visualID 0x2b
      depth 24, visualID 0x2c
      depth 24, visualID 0x2d
      depth 24, visualID 0x2e
      depth 24, visualID 0x2f
      depth 24, visualID 0x30
      depth 24, visualID 0x31
      depth 24, visualID 0x32
    number of attributes: 12
      "XV_SET_DEFAULTS" (range 0 to 1)
              client settable attribute
      "XV_AUTOPAINT_COLORKEY" (range 0 to 1)
              client settable attribute
              client gettable attribute (current value is 1)
      "XV_COLORKEY" (range 0 to -1)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_DOUBLE_BUFFER" (range 0 to 1)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_BRIGHTNESS" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_CONTRAST" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_SATURATION" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_COLOR" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_HUE" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_RED_INTENSITY" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_GREEN_INTENSITY" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_BLUE_INTENSITY" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
    maximum XvImage size: 2048 x 2048
    Number of image formats: 4
      id: 0x32595559 (YUY2)
        guid: 59555932-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x59565955 (UYVY)
        guid: 55595659-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)

et pour pingus j'ai pas tout compris, faut que je me recompile le xdtv ? avec l'option enable xinerama?
Ce xinerama tout le monde en parle et je sais pas ce que c'est. Perso je viens de mater dans la source APT de debian, et je trouve rien...
Puis je avoir plus d'info ?

En tout cas je vais mater sur google avec les quelques infos que je viens de découvrir,


Last edited by Kheo on Wednesday 9 June 2004 22:45:27; edited 1 time in total
View user's profileSend private messageMSN Messenger
pingus
Dévelo XdTV (Linux)


Joined: 21 Dec 2002
Posts: 194

PostPosted: Wednesday 9 June 2004 22:16:58 Reply with quoteBack to top

xinerama = gestion des ecrans multiples.
je penses que tu dois recompiler. en fait xinerama n'est pas actif par défaut donc je suppose que le package deb ne l'a pas
View user's profileSend private message
Kheo
Posteur régulier


Joined: 27 Feb 2003
Posts: 55
Location: Coucou, je suis là ! mais ou tu regardes, j'ai dis ici !!

PostPosted: Wednesday 9 June 2004 22:36:40 Reply with quoteBack to top

ben en fait je me suis fait qq recherches, et j'ai vu qu'il n'y a que enlightment qui gere bien xinerama ( est-ce tjs vrai ca ? ) .
Ensuite quand je lance le serveur X genre startx -- +xinerama ok ca se lance, j'ai des pb des refresh sur le 2eme ecran, disons plutot des pb de frequence de rafraichissement je pense, mais bon j'arrive a le gerer et apres un xvinfo il me dit tjs no adaptator found.

Ah oui j'ai en fait 2 ecrans en clone mode avec xinerama, je peux faire passer une fenetre vers le deuxieme ecran mais en fait elle va qq part on ne sait ou puisque le 2eme ecran est en clone mode. Le pb est que le 2eme ecran n'affiche pas le bon truc. Pis etre tu veux mon fichier XF86Config-4 ?

J'ai une debian en SID et un kernel 2.6.5 compilé et une ATI 9600 ( oui grrr mais bon )

PS : lol xinerama je pensais que c'etait pour mater xine sur deux ecrans schtroumpf enfin je me comprend !
View user's profileSend private messageMSN Messenger
pingus
Dévelo XdTV (Linux)


Joined: 21 Dec 2002
Posts: 194

PostPosted: Wednesday 9 June 2004 23:10:15 Reply with quoteBack to top

je peux pas t'aider plus. j'ai patcher xawdecode pour qu'il ait le support du xinerama. je sais que ca marche car qq l'a testé avec moi pendant la mise en place du support.
je te propose de le contacter.
email moi sur pingus_77 at yahoo dot fr
et je te filerais son email.
bye pingus
View user's profileSend private message
Display posts from previous:      
Post new topicReply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 200-2008 phpBB Group :: FI Theme :: All times are GMT + 1 Hour